به روز شده در ۱۳۹۷/۰۹/۲۳ - ۱۷:۰۷
 
۰
تاریخ انتشار : ۱۳۹۷/۰۷/۰۳ ساعت ۱۱:۰۶
کد مطلب : ۱۶۰۴۸۷

نسخه‌های مختلف ویندوز آسیب پذیرند

گروه فناوری: مرکز مدیریت امداد و هماهنگی عملیات رخدادهای رایانه‌ای نسبت به آسیب پذیری سیستمی جدید در نسخه های مختلف ویندوز هشدار داد.
نسخه‌های مختلف ویندوز آسیب پذیرند
اخیرا ‫مایکروسافت، گزارشی در مورد یک آسیب پذیری مهم Denial of Service منتشر کرده که روی اغلب نسخه های مختلف سیستم عامل ویندوز وجود دارد.این ‫آسیب پذیری، ویندوزهای نسخه ۷ تا ۱۰ ، همچنین ویندوز نسخه ۸.۱ RT و ویندوز سرورهای ۲۰۰۸، ۲۰۱۲ و ۲۰۱۶ را تحت تاثیر قرار می دهد.همچنین نسخه های Core Installation ویندوزهای سرور هم شامل این آسیب پذیری است و متاسفانه در آخرین به روز رسانی های ماه سپتامبر کمپانی مایکروسافت، برای نسخه های مختلف ویندوز، وصله امنیتی برای این آسیب پذیری منتشر نشده است.این آسیب پذیری که دارای شماره شناسایی CVE-۲۰۱۸-۵۳۹۱ است توسط حمله FragmentSmack صورت می گیرد که مربوطه به پاسخ دهنده به درخواست های IP fragmentation بوده و این خود در پروسه تخصیص دادن ماکزیمم سایز پاکت های در حال انتقال یا همان MTU جهت رسیدن به End Node مورد استفاده قرار می گیرد.در حالت کلی حمله IP fragmentation نوعی از حملات جهت DoS کردن هدف است که کامپیوتر قربانی چندین Packet با سایزی کوچکتر از مقداری که انتظار می رود از IP های مختلف دریافت می کند و درگیر شدن بیش از حد سیستم برای reassemble کردن Packet های مربوطه، باعث بوجود آمدن این حمله می شود.

حمله FragmentSmack نوعی از حملات TCP fragmentation است و گاهی آن را با نام Teardrop معرفی می کنند، در حالت کلی باعث جلوگیری از reassembling شدن پاکت ها در مقصد می شود. این آسیب پذیری که از زمان ویندوز ۳.۱ و ویندوز ۹۵ هم وجود داشته و باعث crash شدن سیستم عامل می شد، هم اکنون روی ویندوز نسخه ۷ و بالاتر هم مشاهده شده است.طبق گفته های منتشرشده مایکروسافت، نفوذگر پاکت های متوالی IP Fragment با سایز ۸ بایت که offset های شروعی آنها به صورت تصادفی تعیین شده است را برای قربانی می فرستد، اما با نگه داشتن آخرین fragment و Exploit کردن موفقیت آمیز آسیب پذیری، توسط بالا بردن درصد کارکرد CPU می تواند سیستم قربانی را DoS کند.مایکروسافت تا زمانی که وصله امنیتی رسمی برای این آسیب پذیری ارائه کند، راه حل زیر را برای غیرفعال کردن ساختار Packet Reassembly ارائه کرده که این راه حل باعث جلوگیری از حمله FragmentSmack و DoS شدن سیستم های ویندوزی می شود. این کار توسط اجرای دستورات زیر در سیستم عامل ممکن می شود:
Netsh int ipv۴ set global reassemblylimit=۰
Netsh int ipv۶ set global reassemblylimit=۰
این آسیب پذیری در سیستم عامل های لینوکسی هم منتشر شده که با نام SegmentSmack معرفی شده و شماره شناسایی آن CVE-۲۰۱۸-۵۳۹۰ است. این آسیب پذیری لینوکس هایی با نسخه هسته ۳.۹ و بالاتر را تحت تاثیر قرار می دهد اما در اکثر توزیع های لینوکسی مهم، این آسیب پذیری در به روز رسانی های جدید خود رفع شده است.
مرجع : مهر